Back to overview
Downtime

Product Load Time

Jan 10 at 08:00am EST
Affected services
Products API

Resolved
Jan 10 at 09:00am EST

Issues with Products loading has been resolved

Created
Jan 10 at 08:00am EST

Users may have experienced slow loading of products on the menu page from 8AM to 9AM